Our verification engine service is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Jan 18, 2021 - 01:37 EET
Investigating
We are experiencing some issues with our verification engine and thus the processing times might be slightly slower.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Jan 18, 2021 - 01:03 EET
This incident affected: Services in Europe (Verification Decisions).