Our service is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Apr 14, 2024 - 06:59 EEST
Monitoring
We’ve deployed a fix and the underlying issue has been resolved. Now we are working hard to clear the queue
Posted Apr 14, 2024 - 06:51 EEST
Investigating
Hmm. Something seems to be up with our verification-engine , which can cause slightly longer decision times.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Apr 14, 2024 - 06:13 EEST
This incident affected: SaaS (Verification Decisions), Enterprise Europe (Verification Decisions), and Enterprise USA (Verification Decisions).