Our service is experiencing issues

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 05:33 EET

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 25, 2026 - 04:38 EET

Investigating

Hello! We have identified issues with our decision making service in certain EU clusters;

We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Feb 25, 2026 - 04:09 EET
This incident affected: Enterprise Europe (Verification Decisions).