Our service is experiencing issues

Incident Report for Veriff

Resolved

We have rolled back a failing component deployment that was causing elevated decision times. Following a monitoring period, all systems have returned to normal operation.

We apologize for any inconvenience this may have caused.
Posted Jul 28, 2026 - 17:38 EEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 17:27 EEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 28, 2026 - 17:25 EEST

Update

We are continuing to investigate this issue.
Posted Jul 28, 2026 - 17:25 EEST

Investigating

We are actively monitoring an issue that is causing some automated sessions to experience higher decision times than usual.

This issue is not affecting all sessions, so you may or may not be impacted.

Our team is currently investigating the root cause. We will provide another update as soon as we identify the affected component and have more information to share.
Posted Jul 28, 2026 - 17:00 EEST
This incident affected: Enterprise Europe (Verification Decisions).