Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted May 09, 2022 - 17:19 EEST
Monitoring
Ta-da! The fix is out! We’ve deployed a fix, but to be safe we’re keeping an eye on everything.
Posted May 09, 2022 - 16:18 EEST
Identified
Hmm. Something seems to be up with our Verifications Decision engine. Some decisions might take a bit longer than usual.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted May 09, 2022 - 16:05 EEST
This incident affected: Services in Europe (Verification Decisions).