Elevated decision response times

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 16:18 EEST

Monitoring

We are experiencing elevated decision response times, due to degraded service performance

Traffic was routed away from affected cluster to stop further impact. We will inform you once the incident is resolved

Sorry for the inconvenience!
Posted Aug 26, 2025 - 15:00 EEST
This incident affected: Enterprise USA (Verification Decisions).