Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Aug 31, 2022 - 17:25 EEST
Monitoring
Ta-da! The fix is out! We’ve deployed a fix, but to be safe we’re keeping an eye on everything.
Posted Aug 31, 2022 - 16:40 EEST
Investigating
Hmm. Something seems to be up with webhooks.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Aug 31, 2022 - 14:56 EEST
This incident affected: Enterprise USA (API, Webhooks) and Enterprise Europe (API, Webhooks).