Our service is experiencing issues

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 02:43 EEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 00:32 EEST

Update

We are continuing to investigate this issue.
Posted Jul 08, 2026 - 00:07 EEST

Investigating

We are currently investigating potential degraded performance with Verification Decisions.

Our team is working on identifying root cause of the issue that is contributing to delayed decisions and will provide an update shortly.
Posted Jul 08, 2026 - 00:06 EEST
This incident affected: Enterprise Europe (Verification Decisions) and SaaS (Verification Decisions).