Our verification engine is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Sep 03, 2021 - 19:37 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2021 - 19:34 EEST
Identified
We identified the cause of the issue and are already working on a solution.
As soon as we have more details, we will let you know.
Posted Sep 03, 2021 - 19:30 EEST
Investigating
We are experiencing some issues with our verification engine which can cause slightly longer decision times.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Sep 03, 2021 - 19:20 EEST
This incident affected: Services in Europe (Verification Decisions).