Our verification automation service is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Dec 30, 2020 - 12:56 EET
Monitoring
We're happy to share that our team deployed a fix. But to be safe, we are still keeping a close eye on everything.
Posted Dec 30, 2020 - 12:47 EET
Investigating
We are experiencing some issues with the verification automation service.
Our team is already investigating and will update you as soon as possible.

Some delayed decisions are expected.

We apologize for any inconvenience!
Posted Dec 30, 2020 - 12:36 EET
This incident affected: Services in Europe (Verification Decisions) and Services in America (Verification Decisions).