Our verification engine service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Dec 10, 2021 - 13:11 EET
Update
The new fix is out! We’ve deployed a new fix, but to be safe we’re keeping an eye on everything.
Posted Dec 10, 2021 - 12:17 EET
Update
The initial fix did not work. We are continuing to investigate the root cause.
Posted Dec 10, 2021 - 12:10 EET
Monitoring
Ta-da! The fix is out! We’ve deployed a fix, but to be safe we’re keeping an eye on everything.
Posted Dec 10, 2021 - 12:02 EET
Investigating
We are experiencing some issues with our verification engine which can cause longer decision times.
We identified the cause of the issue and are already working on a solution.
As soon as we have more details, we will let you know.

We apologize for any inconvenience!
Posted Dec 10, 2021 - 11:56 EET
This incident affected: Services in Europe (Verification Decisions).