Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Feb 27, 2022 - 23:04 EET
Monitoring
Ta-da! The fix is out! We’ve deployed a fix, but to be safe we’re keeping an eye on everything.
Posted Feb 27, 2022 - 21:58 EET
Identified
We’ve discovered the cause of the problem - now we’re working hard to get the fix deployed to live as soon as possible! Sorry for the inconvenience!
Posted Feb 27, 2022 - 21:07 EET
Investigating
Hmm. Something seems to be up with Verification Decisions some may take a bit longer than usual.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Feb 27, 2022 - 20:41 EET
This incident affected: Services in Europe (Verification Decisions).