Our verification engine is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Jan 06, 2021 - 15:05 EET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 06, 2021 - 15:00 EET
Investigating
We are experiencing some issues with our verification engine which can cause slighly longer decision times.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Jan 06, 2021 - 14:57 EET
This incident affected: Services in Europe (Verification Decisions).