Our service is experiencing issues

Incident Report for Veriff

Resolved

Following a period of successful monitoring, we have confirmed that the issue is fully resolved.

System metrics have returned to normal and all services are operational.

Thank you for your patience with us.
Posted Jul 25, 2026 - 14:59 EEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2026 - 23:34 EEST

Identified

We have identified an issue affecting one of our third-party providers and are working closely with them to resolve it as quickly as possible.

Because the issue is intermittent, some sessions may experience higher-than-normal decision latency, while others may not be affected.

We will continue to provide updates as more information becomes available.
Posted Jul 24, 2026 - 19:46 EEST

Investigating

We are currently investigating potential degraded performance with Verification Decisions.

Our team is working on identifying root cause of the issue that is contributing to delayed decisions and will provide an update shortly.
Posted Jul 24, 2026 - 15:15 EEST
This incident affected: Enterprise Europe (Verification Decisions), Enterprise USA (Verification Decisions), and SaaS (Verification Decisions).