Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again.

Sorry for the inconvenience!
Posted Jun 01, 2023 - 15:10 EEST
Identified
We’ve discovered the cause of the problem and fixed it - now we’re working hard to reprocess the impacted sessions.
We will keep you updated once the queue is cleared. Sorry for the inconvenience!
Posted Jun 01, 2023 - 14:50 EEST
Investigating
Hmm. Something seems to be up with our verification engine, which can cause slightly longer decision times on manual processings.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Jun 01, 2023 - 14:34 EEST
This incident affected: SaaS (Verification Decisions) and Enterprise Europe (Verification Decisions).