Our core service is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Apr 27, 2020 - 14:02 EEST
Investigating
We are experiencing some issues with our core service which is blocking sessions to be submitted.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Apr 27, 2020 - 13:48 EEST
This incident affected: Services in Europe (API, End User Flow).