Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 05, 2024 - 09:00 EET
Scheduled
Hi there! Just wanted to flag you that we have scheduled maintenance on our Reporting functionality that will take about 60 minutes. During this time, Reporting tab might be unavailable for several minutes. Once it’s done, everything will be working smoothly again. For anything else, please contact us.
Sorry for any inconveniences this may cause.
Posted Nov 29, 2024 - 16:48 EET
This scheduled maintenance affected: SaaS (Reporting), Enterprise Europe (Reporting), and Enterprise USA (Reporting).