Our verification engine service is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Oct 31, 2021 - 15:40 EET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 31, 2021 - 15:25 EET
Investigating
We are experiencing some issues with our verification engine which can cause longer decision times.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Oct 31, 2021 - 15:05 EET
This incident affected: Services in Europe (Verification Decisions) and Services in America (Verification Decisions).