Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Feb 18, 2022 - 23:37 EET
Monitoring
Ta-da! The fix is out! We’ve deployed a fix, but to be safe we’re keeping an eye on everything.
Posted Feb 18, 2022 - 23:03 EET
Update
We are experiencing an issue with our end user flow and we sincerely apologize for the inconvenience this may have caused you.
Posted Feb 18, 2022 - 21:48 EET
Update
We are experiencing an issue with our end user flow and we sincerely apologize for the inconvenience this may have caused you.
Posted Feb 18, 2022 - 21:41 EET
Investigating
Hmm. Something seems to be up with $$
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Feb 18, 2022 - 20:55 EET
This incident affected: Services in Europe (End User Flow).