Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 13, 2025 - 09:00 EEST
Scheduled
Hi there! Just wanted to flag you that we have scheduled maintenance on our database servers that will take about 120 minutes. During this time, users might notice some interruptions. Once it’s done, everything will be working smoothly again. For anything else, please contact us.
Sorry for any inconveniences this may cause.
Posted May 07, 2025 - 14:29 EEST
This scheduled maintenance affected: Enterprise Europe (API, Webhooks, Veriff Station, End User Flow, Verification Decisions, Reporting) and SaaS (API, Webhooks, Veriff Station, End User Flow, Verification Decisions, Reporting).