Our service is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Feb 17, 2022 - 16:36 EET
Monitoring
Ta-da! The fix is out! We’ve deployed a fix, but to be safe we’re keeping an eye on everything.
Posted Feb 17, 2022 - 14:07 EET
Update
We’ve discovered the cause of the problem - now we’re working hard to get the fix deployed to live as soon as possible! Sorry for the inconvenience!
Posted Feb 17, 2022 - 12:20 EET
Update
We’ve discovered the cause of the problem - now we’re working hard to get the fix deployed to live as soon as possible! Sorry for the inconvenience!
Posted Feb 17, 2022 - 11:52 EET
Identified
We’ve discovered the cause of the problem - now we’re working hard to get the fix deployed to live as soon as possible! Sorry for the inconvenience!
Posted Feb 17, 2022 - 10:30 EET
Update
We are continuing to investigate this issue.
Posted Feb 17, 2022 - 10:28 EET
Investigating
Hmm. Something seems to be up with the Verification engine
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Feb 17, 2022 - 10:11 EET
This incident affected: Services in Europe (API, Webhooks, Veriff Station, Verification Decisions).