Our End User flow is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Mar 31, 2021 - 11:41 EEST
Monitoring
We're happy to share that our team deployed a fix.
But to be safe, we are still keeping a close eye on everything.
Posted Mar 31, 2021 - 11:31 EEST
Update
Team is working hard to find solution for this issue. It won't be long now ...
Posted Mar 31, 2021 - 11:21 EEST
Investigating
We are experiencing some issues with End User flow where users are not able to upload images
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Mar 31, 2021 - 10:56 EEST
This incident affected: Services in Europe (End User Flow).