Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.
Sorry for the inconvenience!
Posted Mar 25, 2025 - 16:26 EET
Investigating
Hmm. Something seems to be up with verification decision times. We are checking it out and will update you shortly.
Sorry for the inconvenience!
Posted Mar 25, 2025 - 16:07 EET
This incident affected: Enterprise USA (Verification Decisions).