Our service is experiencing issues

Incident Report for Veriff

Resolved

Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Jan 19, 2024 - 23:05 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 19, 2024 - 22:58 EET

Update

We are continuing to work on a fix for this issue.
Posted Jan 19, 2024 - 22:34 EET

Identified

The issue has been identified and we are working on the fix.
Posted Jan 19, 2024 - 21:33 EET

Update

We are continuing to investigate the issue
Posted Jan 19, 2024 - 21:23 EET

Investigating

Hmm. Something seems to be up with SSN registry validation.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Jan 19, 2024 - 19:22 EET
This incident affected: Enterprise Europe (Verification Decisions) and Enterprise USA (Verification Decisions).