Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 19, 2025 - 08:00 EET
Scheduled
Hi there! Just wanted to flag to you that we are performing a minor database version upgrade. During this time, our central databases will be unavailable for up to 20 seconds several times during the maintenance time window. This means users might notice some interruptions. Once it’s done, everything will be working smoothly again. For anything else, please contact us.
Sorry for any inconvenience this may cause.
Posted Mar 14, 2025 - 13:28 EET
This scheduled maintenance affected: Enterprise Europe (API, Webhooks, Veriff Station, End User Flow, Verification Decisions, Reporting), Enterprise USA (API, Webhooks, Veriff Station, End User Flow, Verification Decisions, Reporting), and SaaS (API, Webhooks, Veriff Station, End User Flow, Verification Decisions, Reporting).