internal network issue
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Mar 03, 2020 - 10:53 EET
Identified
We are experiencing an internal network issue which is causing more processing times . Issue already identified and team is working on the fix.

We apologize for any inconvenience!
Posted Mar 03, 2020 - 10:20 EET