Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Jun 20, 2022 - 16:56 EEST
Identified
We’ve discovered the cause of the problem - now we’re working hard to get the fix deployed to live as soon as possible! Sorry for the inconvenience!
Posted Jun 20, 2022 - 16:44 EEST
Investigating
Hmm. Something seems to be up with our webhooks.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Jun 20, 2022 - 16:39 EEST
This incident affected: Enterprise Europe (Webhooks).