Manual reviews delay

Incident Report for Veriff

Resolved

Hello!

We want to inform you that the incident was successfully resolved, and the manual verification queue has stabilised. Decision times should return to normal from this point forward.

We bring our apologies for any inconvenience caused!
Posted Jan 26, 2026 - 12:14 EET

Update

We are continuing to monitor for any further issues.
Posted Jan 26, 2026 - 11:58 EET

Monitoring

Hello! We want to inform you that due to an internal incident, manual decision making is delayed. A rollback was already made and we are monitoring the situation, the expected queue cleanup time is approximately 5-7 minutes. We will keep you posted
Posted Jan 26, 2026 - 11:58 EET
This incident affected: SaaS (Verification Decisions), Enterprise Europe (Verification Decisions), and Enterprise USA (Verification Decisions).