Our Decision Engine service is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Nov 09, 2021 - 07:56 EET
Monitoring
We're happy to share that our team deployed a fix. But to be safe, we are still keeping a close eye on everything.
Posted Nov 09, 2021 - 06:04 EET
Update
We've deployed some changes and see slight improvements but the final fix is still being worked on.
As soon as we have more details, we will let you know.
Posted Nov 09, 2021 - 05:32 EET
Update
We are still working on the fix, soon everything will be good again.
As soon as we have more details, we will let you know.
Posted Nov 09, 2021 - 04:35 EET
Identified
We identified the cause of the issue and are already working on a solution.
As soon as we have more details, we will let you know.
Posted Nov 09, 2021 - 03:49 EET
Investigating
We are experiencing some longer than usual verification decision times for manual verifications.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Nov 09, 2021 - 03:34 EET
This incident affected: Services in Europe (Verification Decisions) and Services in America (Verification Decisions).