A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2026 - 19:57 EET
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 18, 2026 - 19:50 EET
Update
We are continuing to investigate this issue.
Posted Mar 18, 2026 - 19:18 EET
Update
We are continuing to investigate this issue.
Posted Mar 18, 2026 - 19:13 EET
Update
We are continuing to investigate this issue.
Posted Mar 18, 2026 - 19:10 EET
Investigating
Hmm. Something seems to be up with Verification Flow We are checking it out and will update you shortly.
Sorry for the inconvenience!
Posted Mar 18, 2026 - 18:58 EET
This incident affected: SaaS (End User Flow, Verification Decisions), Enterprise USA (End User Flow, Verification Decisions), and Enterprise Europe (End User Flow, Verification Decisions).