Our verification engine is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Nov 21, 2022 - 18:54 EET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 21, 2022 - 18:38 EET
Identified
We’ve discovered the potential cause of the problem - now we’re working hard to get the fix deployed to live as soon as possible! Sorry for the inconvenience!
Posted Nov 21, 2022 - 18:28 EET
Investigating
Hmm. Something seems to be up with verification engine which can cause slightly longer decision times.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Nov 21, 2022 - 18:11 EET
This incident affected: Flamingo (Verification Decisions), SaaS (Verification Decisions), and Enterprise Europe (Verification Decisions).