Our service is experiencing issues

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 05:10 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2026 - 04:44 EET

Investigating

Hmm. Something seems to be up with the API
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Mar 20, 2026 - 03:32 EET
This incident affected: Enterprise Europe (API) and Enterprise USA (API).