Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2025 - 08:00 EET
Scheduled
Hi there! Just wanted to flag to you that we have scheduled maintenance on our enterprise Hub and SAAS Station that will take about 2 hours. During this time, users might notice some interruptions. Once it’s done, everything will be working smoothly again. For anything else, please contact us.
Sorry for any inconvenience this may cause.
Posted Mar 11, 2025 - 14:40 EET
This scheduled maintenance affected: Enterprise Europe (Veriff Station), Enterprise USA (Veriff Station), and SaaS (Veriff Station).