Longer processing times
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted May 18, 2020 - 12:00 EEST
Investigating
We have been experiencing degraded performance with our verification engine which is causing a bit longer processing times than usual
Posted May 18, 2020 - 10:00 EEST
This incident affected: Services in Europe (Verification Decisions).