Our service is experiencing issues

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Jun 30, 2026 - 18:40 EEST

Identified

The root cause of the issue has been identified.

Our team is prioritized on deploying a fix.
Posted Jun 30, 2026 - 18:33 EEST

Investigating

We have identified an issue affecting manual verifications that may cause delays in verification decisions.

Our team is actively investigating the root cause and working to resolve the issue as quickly as possible. We will provide updates as more information becomes available.
Posted Jun 30, 2026 - 18:22 EEST
This incident affected: Enterprise Europe (Verification Decisions), Enterprise USA (Verification Decisions), SaaS (Verification Decisions), and Unidentified Component.