Our API is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Dec 17, 2020 - 17:11 EET
Monitoring
We're happy to share that our team deployed a fix. But to be safe, we are still keeping a close eye on everything.
Posted Dec 17, 2020 - 17:02 EET
Investigating
We are experiencing some issues with Veriff Station currently.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Dec 17, 2020 - 17:00 EET
This incident affected: Services in Europe (API, Veriff Station).