We are experiencing internal network issues which can cause delay on processing times.

Incident Report for Veriff

Resolved

All good! Everything is operational again, and we thank you for your patience.
Posted Apr 24, 2020 - 07:00 EEST

Monitoring

We're happy to share that our team deployed a fix. But to be safe, we are still keeping a close eye on everything.
Posted Apr 24, 2020 - 06:51 EEST

Update

We are continuing to work on a fix for this issue.
Posted Apr 24, 2020 - 06:45 EEST

Identified

We're happy to share that our team deployed a fix. But to be safe, we are still keeping a close eye on everything.
Posted Apr 24, 2020 - 06:30 EEST