Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Jun 03, 2022 - 13:42 EEST
Update
We are continuing to monitor for any further issues.
Posted Jun 03, 2022 - 13:42 EEST
Monitoring
Ta-da! The fix is out! We’ve deployed a fix, but to be safe we’re keeping an eye on everything.
Posted Jun 03, 2022 - 13:27 EEST
Identified
We’ve discovered the cause of the problem - now we’re working hard to get the fix deployed to live as soon as possible! Sorry for the inconvenience!
Posted Jun 03, 2022 - 13:25 EEST
Update
We are continuing to investigate this issue.
Posted Jun 03, 2022 - 13:25 EEST
Investigating
Hmm. Something seems to be up with verification checks.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Jun 03, 2022 - 13:13 EEST
This incident affected: Services in Europe (Verification Decisions) and Services in America (Verification Decisions).