Elevated decision response times

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Oct 27, 2025 - 22:50 EET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 27, 2025 - 22:30 EET

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 27, 2025 - 21:15 EET

Investigating

We are experiencing a delay in our decision-making process, which in turn is impacting the verification time.
Posted Oct 27, 2025 - 20:25 EET
This incident affected: SaaS (Verification Decisions) and Enterprise Europe (Verification Decisions).