Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.

Sorry for the inconvenience!
Posted Jul 06, 2024 - 01:19 EEST
Monitoring
Thank you for your continued understanding and patience.

We are pleased to inform you that we have applied a fix which we believe has resolved the issue. We will continue to monitor the situation closely to ensure the solution is effective and has indeed worked.

Thank you for your understanding and patience once again!
Posted Jul 06, 2024 - 00:45 EEST
Update
Thank you for your continued understanding and patience.

We believe we have identified the cause of the incident and are now working towards implementing a solution with our provider.

In the meantime, customers can still create sessions with us but may experience delays in decision times. We are committed to resolving this issue and will provide further updates as soon as possible.
Posted Jul 06, 2024 - 00:04 EEST
Identified
Thank you for your continued understanding and patience.

We believe we have identified the cause of the incident and are now working towards implementing a solution with our provider.

In the meantime, customers can still create sessions with us but may experience delays in decision times. We are committed to resolving this issue and will provide further updates as soon as possible.
Posted Jul 05, 2024 - 23:29 EEST
Update
Thank you for your continued understanding and patience.

Please know that we are actively working through the issue with our third-party provider and hope to resolve it as soon as possible. The resolution is taking longer than expected, but we have escalated the issue and have the right team working on it.

In the meantime, customers can still create sessions with us, but may experience delays in decision times. We are committed to resolving this issue and will provide further updates as soon as possible.
Posted Jul 05, 2024 - 22:49 EEST
Update
Thank you for your continued understanding and patience.

Please know that we are actively working through the issue with our third-party provider and hope to resolve it as soon as possible. The resolution is taking longer than expected, but we have escalated the issue and have the right team working on it.

In the meantime, customers can still create sessions with us, but may experience delays in decision times. We are committed to resolving this issue and will provide further updates as soon as possible.
Posted Jul 05, 2024 - 22:15 EEST
Update
Thank you for your continued understanding and patience.

Please know that we are actively working through the issue with our third-party provider and hope to resolve it as soon as possible. The resolution is taking longer than expected, but we have escalated the issue and have the right team working on it.

In the meantime, customers can still create sessions with us, but may experience delays in decision times. We are committed to resolving this issue and will provide further updates as soon as possible.
Posted Jul 05, 2024 - 21:46 EEST
Update
Thank you for your continued understanding and patience.
Please know that we are actively working through the issue with our third-party provider and hope to resolve it as soon as possible. In the meantime, customers can still create sessions with us, but may experience delays in decision times. We are committed to resolving this issue and will provide further updates as soon as possible.
Posted Jul 05, 2024 - 21:16 EEST
Update
Thank you for your continued understanding and patience.
Please know that we are actively working through the issue with our third-party provider and hope to resolve it as soon as possible. In the meantime, customers can still create sessions with us, but may experience delays in decision times. We are committed to resolving this issue and will provide further updates as soon as we have more information.
Posted Jul 05, 2024 - 20:45 EEST
Update
Thank you for your patience.
Our team is continuing to investigate the issue and we are working together with our third-party provider to resolve it as a high priority. We will provide further updates as soon as possible.
Posted Jul 05, 2024 - 20:10 EEST
Update
We are currently investigating this issue.

We are sorry for the inconvenience.
Posted Jul 05, 2024 - 19:40 EEST
Investigating
We are currently investigating this issue.
Posted Jul 05, 2024 - 19:10 EEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 05, 2024 - 19:09 EEST
Update
We are continuing to work on a fix for this issue.
Posted Jul 05, 2024 - 18:31 EEST
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 05, 2024 - 17:58 EEST
Update
We are continuing to investigate this issue.
Posted Jul 05, 2024 - 17:26 EEST
Update
We are still investigating the issues with the verification decisions.
We are checking it out and will update you shortly.

We are sorry for the inconvenience.
Posted Jul 05, 2024 - 17:01 EEST
Update
We are still investigating the issues.

We are sorry for the inconvenience.
Posted Jul 05, 2024 - 16:10 EEST
Update
We are still investigating the issues.

We are sorry for the inconvenience.
Posted Jul 05, 2024 - 15:07 EEST
Investigating
Hmm. Something seems to be up with verification decisions.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Jul 05, 2024 - 14:02 EEST
This incident affected: SaaS (Verification Decisions), Enterprise Europe (Verification Decisions), and Enterprise USA (Verification Decisions).