Our verification engine is experiencing some issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Dec 15, 2020 - 10:12 EET
Investigating
We are experiencing some issues with our verification engine which can cause sligtly longer decision times.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Dec 15, 2020 - 09:55 EET
This incident affected: Services in Europe (Verification Decisions).