Our service is experiencing issues

Incident Report for Veriff

Resolved

This incident has been resolved.
Posted Sep 04, 2026 - 09:20 EEST

Update

We are continuing to monitor for any further issues.
Posted Sep 04, 2026 - 02:02 EEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 04, 2026 - 01:36 EEST

Update

An issue has been identified with one of our third party providers causing an increase in auto verification decision times in our US regions.
Posted Sep 04, 2026 - 01:34 EEST

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 04, 2026 - 01:30 EEST

Investigating

We are currently investigating potential degraded performance with Verification Decisions.

Our team is working on identifying root cause of the issue that is contributing to delayed decisions and will provide an update shortly.
Posted Sep 04, 2026 - 01:18 EEST
This incident affected: Enterprise Europe (Verification Decisions), Enterprise USA (Verification Decisions), and SaaS (Verification Decisions).