Our verification engine is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Mar 30, 2021 - 17:24 EEST
Monitoring
We're happy to share that we a fixed the issue. But to be safe, we are still keeping a close eye on everything.
Posted Mar 30, 2021 - 16:54 EEST
Update
Update: End user flow is functional and and new sessions can be submitted again.
Verification decision are also working but there are still some works to be done to be back 100%
Posted Mar 30, 2021 - 16:47 EEST
Update
Update: We did emergency maintenance on our infrastructure, it did improve the situation but we're still not out of the woods.
As soon as we have more details, we will let you know.
Posted Mar 30, 2021 - 16:33 EEST
Identified
We identified the cause of the issue and are already working on a solution.
As soon as we have more details, we will let you know.
Posted Mar 30, 2021 - 16:15 EEST
Update
We are continuing to investigate this issue.
Posted Mar 30, 2021 - 15:57 EEST
Investigating
We are experiencing some issues with our verification engine.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Mar 30, 2021 - 15:30 EEST
This incident affected: Services in Europe (End User Flow, Verification Decisions).