Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Everything is working smoothly once again. If anything still seems not working properly, please clear your browser cache and cookies for the Veriff page and try again. For anything else, please contact us.
Posted Dec 13, 2022 - 10:08 EET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 13, 2022 - 10:04 EET
Investigating
Hmm. Something seems to be up with our services.
We are checking it out and will update you shortly.
Posted Dec 13, 2022 - 09:42 EET
This incident affected: SaaS (Verification Decisions), Enterprise Europe (Verification Decisions), and Enterprise USA (Verification Decisions).