Our pep-check service is experiencing issues
Incident Report for Veriff
Resolved
This incident has been resolved.
Posted Mar 31, 2020 - 15:28 EEST
Investigating
We are experiencing some issues with PEP Sanction checks .
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Mar 31, 2020 - 13:56 EEST