Our BackOffice name search is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Sep 02, 2020 - 15:27 EEST
Update
We are continuing to investigate this issue.
Posted Sep 02, 2020 - 14:26 EEST
Investigating
We are experiencing some issues with our BackOffice name search.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Sep 02, 2020 - 14:26 EEST