Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now and queue is back to normal! Everything is working smoothly once again.
For anything else, please contact us.

Sorry for the inconvenience!
Posted Dec 21, 2023 - 23:19 EET
Investigating
This is just to update that our backlog is a bit longer then usual and it takes a little longer to process all the sessions
We are working actively to clear the queue and will update you shortly once everything is back to normal.

Sorry for the inconvenience!
Posted Dec 21, 2023 - 22:31 EET
This incident affected: SaaS (Verification Decisions), Enterprise Europe (Verification Decisions), and Enterprise USA (Verification Decisions).