Our service is experiencing issues
Incident Report for Veriff
Resolved
Phew, it’s all good now! Real-time verification experience is back! Sorry for the inconvenience!
Posted Aug 28, 2024 - 15:15 EEST
Investigating
Hmm. Some verification decisions might receive delayed responses.
We are checking it out and will update you shortly.

Sorry for the inconvenience!
Posted Aug 28, 2024 - 15:03 EEST
This incident affected: SaaS (Verification Decisions), Enterprise Europe (Verification Decisions), and Enterprise USA (Verification Decisions).