Our verification engine service is experiencing issues
Incident Report for Veriff
Resolved
All good! Everything is operational again, and we thank you for your patience.
Posted Jul 04, 2020 - 20:34 EEST
Investigating
We are experiencing some issues with our verification engine that can cause slightly longer decision times.
Our team is already investigating and will update you as soon as possible.

We apologize for any inconvenience!
Posted Jul 04, 2020 - 20:19 EEST
This incident affected: Services in Europe (Verification Decisions).