Our service is experiencing issues

Incident Report for Veriff

Resolved

Following a period of successful monitoring, we have confirmed that the issue is fully resolved.

System metrics have returned to normal and all services are operational.

Thank you for your patience with us.
Posted Jun 18, 2026 - 21:59 EEST

Monitoring

We identified an issue affecting the search service in Veriff Station that caused some search requests to fail and return errors.

The issue has been resolved, and a fix has been deployed. We are actively monitoring the service to ensure continued stability and performance.
Posted Jun 18, 2026 - 18:56 EEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2026 - 18:03 EEST

Investigating

Thank you for your patience. We have identified the components with the issue.

Our team is actively investigating the root cause, and we will share a status update shortly.
Posted Jun 18, 2026 - 17:39 EEST
This incident affected: Enterprise Europe (Veriff Station) and SaaS (Veriff Station).